Oculus VR与Unity Jump Start

amin | 单职业迷失传奇 | 707 | 707| 2019-11-07 12:06

总是退出潜入新科技,如果你等了很久,没有什么可比的了。

所以我有时间亲自研究和开发并掌握Oculus Rift开发套件(DK1),并意识到这有点太晚了。从一方面来看,有关该技术的所有内容都处于测试版和原型制造状态。从另一方面来看,一切都在快速发展,DK1已经过时了。几乎所有的演示和游戏都没有启动并运行我的硬件%)

现在几乎所有东西都能从盒子里顺利运转,这是令人惊讶的。所以我开始挖掘出什么了:)

首先出现DK1无法在直接模式下工作,然后出现不支持移动GPU。较新的Oculus SDK 0.7无法与Oculus DK1的过时硬件一起正常工作。所以对我来说这看起来像死路一条:)

我担任管理职位太长时间没有让别人为我解决任务。我的朋友程序员我们在非移动PC上测试了头盔。他打算调整/构建我们的最新游戏Naughty Who?在我度假期间的Oculus Rift。不幸的是,幸运的是,他花了一两天的时间来使用驱动程序和SDK集成支持并放弃了。

所以这成了我的个人任务。当然,我认为我应该采取Oculus DK2并忘记问题。 Oculus开发套件2似乎只运送到8个国家,并且我的名单并不令人惊讶,它已售罄。另外DK2对于新的控制器来说还不错,但是我还不知道如何获得它。

它可能看起来像一个问题并再次死锁,它根本不存在。虚拟现实项目和至少Oculus仍然处于测试阶段,我会说原型阶段(不确定Morpheus / PlayStation VR)。因此,这不是最新/最好的硬件问题,而是测试您的游戏或/和(预)塑造它的任何工作硬件的问题。现在我明白Cardboard是个好主意。 ?

运行演示然后编写您的“Hello World”对于我开始处理的每项新技术都是很自然的。也许这太老式了,我还不知道更好的方式。我去了尚未存储的商店并命名为Oculus Share以获得Rollercoaster演示。我已经在商场试过了。哎呀,再一次,它只与DK2兼容:P我已经尝试了大量的演示和游戏,正如我已经提到过的,几乎没有一个能够正常运行。已经发布的几个游戏/演示之一,没有粉碎,看起来像虚拟现实图片,但不是随机移位的一个需要XBOX控制器播放%)我也接近放弃了,托斯卡纳演示了:)

演示运行。让我们进入“Hello World”阶段。很有趣,它花了我几天的实时和几个星期。基本上有两篇文章可以帮助混合帮助脚本和强烈的意愿:Unity Tutorial Rollaball Intro如果你有DK2我应该从盒子里工作吗?开始使用Unity和Oculus Rift SDK 0.4.0(实际为0.4.4)。

第一个有用的提示在Oculus网站的下载部分中有旧的以前的软件。超过0.4版本的第二个SDK用于第二个开发工具包,专用于优化,帧速率,响应时间和延迟等,但不支持后向兼容性。关于Unity的情况大致相同,许可模式从第4版变为第5版,Unity 3.2中的Pro在Unity 5.2中是免费的,它完全不同(%)

使用Oculus PC SDK 0.4.4 Beta附带的单一软件包实现与旧版Unity的集成。你只需要像往常一样导入它。 OVR(OculusVR)Camera Rig和OVR Player Controller有2个预制件,4个脚本管理和修改编辑器游戏视图并构建场景。它们在Unity Editor中工作,不依赖于GPU硬件和Oculus输出预编译的.dll。感谢Google,Reddit和Unity Answers,它们可以收集信息来解决这个问题以及来自Getting的黑客想法?特别是Unity和Oculus Rift SDK文章开始。

现在我只是将游戏窗口的大小调整为1280x800并在头盔屏幕上观看:)我没有像文章建议的那样设法这样我使用Unity编辑器定制并缩放/放置窗口/视口正确脚本构成了Unity的答案。

现在我已经获得了我的“Hello World”在这种情况下使用带有Unity 5.2.1f1的HDMI在移动GPU上使用SDK 0.4.4滚动播放Oculus DK1的演示。

当然它是真空中的球形马:)看起来新版本的SDK是相同的,只是来源,可以查看/修改/重新编译/相同的W

总是退出潜入新科技,如果你等了很久,没有什么可比的了。

所以我有时间亲自研究和开发并掌握Oculus Rift开发套件(DK1),并意识到这有点太晚了。从一方面来看,有关该技术的所有内容都处于测试版和原型制造状态。从另一方面来看,一切都在快速发展,DK1已经过时了。几乎所有的演示和游戏都没有启动并运行我的硬件%)

现在几乎所有东西都能从盒子里顺利运转,这是令人惊讶的。所以我开始挖掘出什么了:)

首先出现DK1无法在直接模式下工作,然后出现不支持移动GPU。较新的Oculus SDK 0.7无法与Oculus DK1的过时硬件一起正常工作。所以对我来说这看起来像死路一条:)

我担任管理职位太长时间没有让别人为我解决任务。我的朋友程序员我们在非移动PC上测试了头盔。他打算调整/构建我们的最新游戏Naughty Who?在我度假期间的Oculus Rift。不幸的是,幸运的是,他花了一两天的时间来使用驱动程序和SDK集成支持并放弃了。

所以这成了我的个人任务。当然,我认为我应该采取Oculus DK2并忘记问题。 Oculus开发套件2似乎只运送到8个国家,并且我的名单并不令人惊讶,它已售罄。另外DK2对于新的控制器来说还不错,但是我还不知道如何获得它。

它可能看起来像一个问题并再次死锁,它根本不存在。虚拟现实项目和至少Oculus仍然处于测试阶段,我会说原型阶段(不确定Morpheus / PlayStation VR)。因此,这不是最新/最好的硬件问题,而是测试您的游戏或/和(预)塑造它的任何工作硬件的问题。现在我明白Cardboard是个好主意。 ?

运行演示然后编写您的“Hello World”对于我开始处理的每项新技术都是很自然的。也许这太老式了,我还不知道更好的方式。我去了尚未存储的商店并命名为Oculus Share以获得Rollercoaster演示。我已经在商场试过了。哎呀,再一次,它只与DK2兼容:P我已经尝试了大量的演示和游戏,正如我已经提到过的,几乎没有一个能够正常运行。已经发布的几个游戏/演示之一,没有粉碎,看起来像虚拟现实图片,但不是随机移位的一个需要XBOX控制器播放%)我也接近放弃了,托斯卡纳演示了:)

演示运行。让我们进入“Hello World”阶段。很有趣,它花了我几天的实时和几个星期。基本上有两篇文章可以帮助混合帮助脚本和强烈的意愿:Unity Tutorial Rollaball Intro如果你有DK2我应该从盒子里工作吗?开始使用Unity和Oculus Rift SDK 0.4.0(实际为0.4.4)。

第一个有用的提示在Oculus网站的下载部分中有旧的以前的软件。超过0.4版本的第二个SDK用于第二个开发工具包,专用于优化,帧速率,响应时间和延迟等,但不支持后向兼容性。关于Unity的情况大致相同,许可模式从第4版变为第5版,Unity 3.2中的Pro在Unity 5.2中是免费的,它完全不同(%)

使用Oculus PC SDK 0.4.4 Beta附带的单一软件包实现与旧版Unity的集成。你只需要像往常一样导入它。 OVR(OculusVR)Camera Rig和OVR Player Controller有2个预制件,4个脚本管理和修改编辑器游戏视图并构建场景。它们在Unity Editor中工作,不依赖于GPU硬件和Oculus输出预编译的.dll。感谢Google,Reddit和Unity Answers,它们可以收集信息来解决这个问题以及来自Getting的黑客想法?特别是Unity和Oculus Rift SDK文章开始。

现在我只是将游戏窗口的大小调整为1280x800并在头盔屏幕上观看:)我没有像文章建议的那样设法这样我使用Unity编辑器定制并缩放/放置窗口/视口正确脚本构成了Unity的答案。

现在我已经获得了我的“Hello World”在这种情况下使用带有Unity 5.2.1f1的HDMI在移动GPU上使用SDK 0.4.4滚动播放Oculus DK1的演示。

当然它是真空中的球形马:)看起来新版本的SDK是相同的,只是来源,可以查看/修改/重新编译/相同的W

相关文章

Copyright © 2019 - 2020 超变单职业 http://www.167hk.com All Rights Reserved.